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Introduction

WHAT IS ARACHNID?

Arachnid is a Macintosh application for graphically designing layouts for World Wide Web
pages. Until now, the tools for building WWW pages have mainly been limited to specialized
Text Editors, directly generating the HTML code which describes every aspect of every ele-
ment of a Web page.

Using existing HTML editors to create web pages is a difficult and time-consuming process.
Even more difficult is the challenge of defining the interactivity of various elements of a page.
Usually this process involves the direct typing of a long URL address or file name. Of course,
there is no way to test the accuracy of the information entered until you open the HTML file
with a browser application and test the link directly.

Recent developments by commercial Browser application vendors, and extensions to the
HTML itself, have led to even higher degrees of interactivity and graphical detail that Web
page authors can incorporate into their work. The process of creating interactive Form pages is
even more challenging at the pure HTML level, as you can get no sense of what objects will
look like until they are viewed with the browser application.

To create a pop-up menu like the one below:

the following HTML code is required
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Arachnid contains tools for drawing the Form object directly on the screen, and a simple inter-
face for creating the menu and its items. In the Active mode, the menu pops up and behaves as
it would if viewed by a Browser application. Similarly, other Form objects behave in the Active
mode in the same manner that they will when viewed with your Browser.

WHO CAN USE ARACHNID?

Arachnid is designed for anyone who wants to build Web pages. It is not an HTML editor—it
is an HTML file builder. Arachnid can convert any page layout it creates to HTML, and can
build a page from an existing HTML file—but in neither case does the user see the HTML
code. Files created with Arachnid are ordinary text files, which can be opened by any text
editor for further editing at the HTML level.

Unlike most tools for creating HTML files, Arachnid removes you entirely from the HTML
code. All page design and linking is done within Arachnid. An HTML file is generated only
when you choose “Export to HTML.” This file can then immediately be opened by your favor-
ite WWW Browser. You can also open the HTML file with any text editor to view or edit the
HTML code. Arachnid is simple enough that anyone can use it to design part or all of a WWW
page’s design, layout, and interactivity. Experienced WWW page designers can begin in
Arachnid and then customize their HTML code later in a word processor.

While Arachnid does not support every HTML feature, many features supported only by
NetScape’s Navigator are definable within Arachnid. Arachnid attempts to deliver WYSIWYG
design capabilities, and to even attempt to achieve this, it must enforce certain limitations. The
main limitations are in the area of object alignment on a page. ALL objects are assumed to be
aligned to the top left-hand corner of a page.
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Finally, a third image is imported.
Its top is snapped to the bottom
edge of the objects in the row
above it.

The second image is dragged in line with
the first image. Notice that the top of the
gray rectangle is below the top edge of
the first image; its left edge is to the right
of the first image’s right edge.

A single image
is imported. It
snaps to the
top left-hand
corner of the
page.

After the drag, this is how the page
looks.

ALIGNING OBJECTS IN ARACHNID

When you drag an object in line with another object, the one you are moving will snap into
line with the other object, with its left and top edges snapped to the right and top edges of the
other object. Two important considerations arise from this limitation: objects cannot be reposi-
tioned on a page until there are at least two objects on the page; and text fields with multiple
lines that are dragged in line with other objects will not translate perfectly to HTML.

A second image is im-
ported. It snaps to the
bottom of the first image,
and to the left-hand side
of the page.
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WHAT TOOLS DOES ARACHNID PROVIDE FOR DEVELOPING A WEB PAGE?

Arachnid contains tools for creating and editing text, importing GIF in-line image files, creat-
ing horizontal rulers—and a whole suite of tools for defining the interactive objects needed to
turn a simple WWW page into a Form.

Much of the power of WWW pages comes from the interactive hypertext and hypergraphic
links to other resources embedded within a standard web page. Arachnid functions as an
authoring tool for defining and testing the interactive links you embed within text and graph-
ics. Using a simple drag-and-drop interface, Arachnid automates the process of creating links
to virtually anything which can be accessed via the internet, including the full set of standard
multimedia file formats.

When you enter the Active mode, an Arachnid page functions nearly the same as when ex-
ported as HTML and opened by a Browser. This allows a WWW page author to test the behav-
ior of many, if not all, of a page’s interactive links. Arachnid includes full playback support for
multimedia file formats such as audio AIFF, video QuickTime, and PICT, JPEG, or GIF image
files.

When linking to locally stored files of other formats, Arachnid uses an approach similar to the
Helper Application method that WWW Browsers use: Arachnid attempts to open the docu-
ment with the application that created it.  Connections to remote URLs are not a function of
Arachnid, and clicks on links to URLs will simply trigger a message that the object is linked to
the URL address displayed within the message.

So that you can take full advantage of its Active mode, Arachnid comes with an accompanying
application, Arachnid Player. This application allows you “Run” an Arachnid project exclu-
sively in the Active mode (i.e., no editing is possible). By using the Player, you can distribute
an Arachnid project on more traditional media such as disks or CD-ROM. You may distribute
the Player application freely, provided you are distributing your project freely. If you wish to
charge for distribution of your project, licensing arrangements will need to be made with the
following developers whose XCMD and XFCNs are used in Arachnid:

Fredrico Rinaldi

Rinaldi1@applelink.apple.com

Mark Hanrek and the Information Workshop

hanrek@cts.com

Jeff Benjamin

AOL: DYNAMIC3

ALink: DYNAMIC
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ARACHNID’S DOCUMENTS: ANATOMY OF AN ARACHNID PROJECT AND PAGE

The basic document that Arachnid creates and manages is called a Project. Because most sites
on the Internet contain several linked pages stored locally, Arachnid Projects are made up of a
collection of pages. A Project always contains at least one page, but it can contain a virtually
unlimited number of pages. Any number of Arachnid pages can be open at once; each page
appears in its own window. Multiple projects can be open at the same time, and entire pages
can be copied and pasted between projects.

An Arachnid page is fixed horizontally. [This may change, but currently it is fixed to the ap-
proximate size of a default page window opened by most Browsers.] Vertically, an Arachnid
page will grow to accommodate as much space as needed, up to a maximum height of about
35 page, each 10 inches tall. Arachnid is NOT optimized for pages this large. The simple pro-
cess of creating, formatting and linking to new pages makes Arachnid ideal for creating sites
with many small pages linked together. The benefit of this approach is much faster load times
for small pages, resulting in reduced loads on servers.

Creating links among multiple pages is a very simple process which, like virtually all other
kinds of linking, can be previewed in the Active mode. The behavior of links among pages in
the same project, and links to spans of text on any page within a project, can be previewed in
the Active mode.

When a page from a project is open, the name of the window it appears in is NOT the name of
the page, but the name of the project itself and the number of the page within the project (for
all but the first page). The reason for this is to help you identify what the name of the HTML
file will be after a page is exported. All HTML files are named as a combination of the Project
name, the number of the page within the project, and the “.html” extension.

Arachnid handles these naming conventions automatically. All you need to do is save your
project with a valid project name (which Arachnid also manages). For example, a project
named “Default” contains 5 pages. You open page 5 of this project. It opens in a window
named “Default-5”. After exporting to HTML, there will be a text file named “Default-5.html”
in the same folder as the project “Default”. This file can immediately be opened by a Browser
or a Text editing program of any kind for additional editing at the HTML level.
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MANAGING PAGES: TEMPLATES

Often times, the layout you create for a given page is intended to be duplicated. Arachnid
stores templates you create in a built-in database. Any open page can be saved as a template.
Initially, only the Default, blank page is stored in the template database. After you have added
a page to the template database, you will notice different behavior whenever you create a new
page. Instead of creating a completely blank page, Arachnid gives you three options: • create
the page with a blank layout

• create the page with the Default template you have specified

• see the list of templates and choose one to use

The View command is in the Edit menu. The subcommand “View Template List” opens a file
dialog containing the list of templates you’ve saved.

Within this Dialog, you can remove templates from the list, rename a template you have saved,
or select a template and designate it as the new Default page. If you designate a page as a
default, and then delete all of the rest of the templates. Arachnid will ALWAYS create new
pages based on that template.
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ANATOMY OF A PAGE

A page in Arachnid consists of standard objects common to most WWW sites: text fields,
horizontal rulers (divider lines), and in-line GIF images.

You create text fields by choosing the Text Edit tool and clicking somewhere on the page where
there is not already an object. You can also use the “Import Text” command-T in the File menu
to create an automatic text field for imported text. If a field is already open for editing when
you choose to import text, the text will appear in the open field. Text fields can contain as little
as a single character, or as much as 30,000 characters. But placing large amounts of text in a
single field results in a noticeable slow-down. It is much better to create many fields containing
a few thousand characters each.

The same layout viewed with the Pointer tool selected. Notice that the out-
lines of most objects, including transparent text fields, are visible when the
Pointer tool is chosen.

An Arachnid page with five separate objects, including two images, two
rulers, and one text field.
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To create rulers, use the Insert Ruler command-R from the File menu. Rulers are drawn on the
screen, where they can be selected, moved, or cloned. Rulers are the one class of objects which
can be aligned and scaled, both horizontally and vertically. Rulers are always the ONLY object
within a given row, so dragging a Ruler on top of another object will shift the Ruler above the
object and any other objects within that row.

Any locally stored GIF image file with a valid UNIX name and extension can be imported into
a page, using the “Import Image” command-I from the File menu.  Once imported, the image
can be linked to, cloned, or repositioned relative to other objects. Arachnid will not let you
import a file with an invalid name, or a file that is not stored in the same folder as your project.

Currently, Arachnid does not support object alignment for objects other than Rulers. ALL
objects are snapped to the top left-hand corner of a page. Objects can be repositioned only in
relation to other objects. Dragging an object will have no effect until there are at least two
objects on the page.

Depending on the size of an object (the amount of text in a field, or the physical width of a
graphic or Form button or field), it may be placed in line with other objects. Objects of any
kind can be placed in line with each other, except for Rulers. All objects in the same physical
row will have their top edges aligned.

Six separate objects in line within the same row: an image followed by a text field, another image, a second
text field, and finally two interactive Radio buttons from the Forms controls.
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Getting Started

When you launch Arachnid, a new project is created, with the name “Untitled-1”. Whenever
you create a new project, the first page opens in the Text edit mode, allowing immediate text
entry. When you open a page that already contains objects, Arachnid opens the page in the
Active more, ready to allow testing of interactive links.

You can create new projects at any time using the New Project command in the File menu, or
by typing command-N. You can open any existing project by using the Open Project command
in the File menu, or by typing command-O.

Any number of projects can be open at once. Objects can be copied and pasted to other pages,
even from one project to another, and entire pages can be duplicated, even to other projects.

Any page layout you create can be saved as a template. This command (Save Page as Tem-
plate) is in the File menu, grouped with the standard “Save” and “Save as.. “ commands. Once
you have saved a page layout as a template, you can create new pages based on this template,
including a “Default” template, which you can designate and change over time.

Once you have created or opened a project, you create objects within the page using tools from
the Tool palette and commands from the File menu. With the Text Edit tool selected, you can
click on any blank space within the page to create a new, active text field. Using other com-
mands from the File menu, you can import graphic files (the “Import Picture” command),
create rulers (the “Insert Ruler” command), import text files (the “Import Text” command),
and import existing HTML files (the “Convert HTML Text File” command).

After you have create or placed at least two objects on a page, you can use the Pointer tool to
select, clone, and reposition objects within a page.
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Building a Page
 . . . using the Tool palette and a few commands from the File menu

Virtually all of Arachnid’s functionality is contained with a single Tool palette.

The palette contains five rows: Navigation, Mode, Links, Forms, and Tool Descriptions

NAVIGATION

The first row contains controls for navigating within your project. It includes buttons for open-
ing the previous or next page from the current page. A Home icon always opens the first page
in the project. Finally, a pop-up menu allows you to open any page in the project.

a

previous page

next page

first page

pop-up menu of all pages

collapse/expand
button

The next 3 rows in the palette contain tools for changing the mode Arachnid is running in,
tools for creating interactive Form objects, and tools for linking files and URLs to text and
graphics.
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Arachnid Modes
There are three basic modes in Arachnid, initiated with the three buttons in the second row of
the Tool palette.

a

Browse Tool: allows you to
use the document in runtime
(Active Mode). Text is locked,
links are active.

Pointer Tool: click to select
any object. Reposition the
object, or cut/copy/paste.

Text Edit Tool: text fields are
editable. Links are not active.

In the Edit Text Mode (The icon with the letter “A”) you can create or edit a text field. Nothing
but text can be edited in this mode; clicking on linked graphics will produce no response.

In the Selection Mode (the Pointer icon), you can select, move, cut, copy, or paste any item,
even to a different page.  Remember, objects can be repositioned only with respect to other
objects, so until there are at least two separate objects on a page, nothing can be repositioned.

Choosing the Active Mode (the Finger icon) puts Arachnid into runtime operation. Normal
text fields are locked and cannot be edited. Clicks on linked text and graphics produce the
desired behavior,  opening the linked pages, movies, sounds, and graphics. The exception is
that links to URLs do not actually connect; instead, a message containing the address is given
to let you know that the link is intact.
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Arachnid’s Tools

Arachnid’s File menu contains commands for creating the additional information you will
want to place on your page:

Import Picture allows you to select any GIF image file and import it directly onto your page,
where it can be positioned and cloned.

Insert Ruler places a straight dividing line across the bottom of your page. Rulers can be
repositioned, aligned, and scaled (both horizontally and vertically).

Import Text prompts you to choose a text file to import into a page. You can import an
unformatted ASCII text file or a fully formatted RTF text file. RTF files are limited to 30000
characters maximum. ASCII text files have no size restrictions.

Convert HTML File prompts you to select an HTML text file, which is imported and con-
verted into an Arachnid page. If the current page has no objects, the converted page will be-
come the current page. Otherwise, a new page is created to accommodate the HTML file.
*Note: there is also a VERY useful command to “Export to HTML”. Use this to convert a page
(or entire project) to a series of HTML files.
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Arachnid Linking

The third row of the Tool palette contains tools for defining interactive links between spans of
text or in-line images. Use these tools to link to:

                        • a specific URL address

                        • a local page

                        • text within a local page

                        • a multimedia file (image, audio, movie)

                        • a file of any type (useful for downloadable files)

To use these tools, select some text that you wish to be linked. Click the icon for the type of link
you want to create, and drag the icon (notice the faint gray rectangular outline following the
cursor) over the selected text.
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Building Arachnid Forms

The fourth row of the Tool palette contains a set of eight tools for creating the interactive ob-
jects your page will need if it is to become a Web Form. (A Web Form can present information
from a database, provide advanced navigation features, and collect user input—all via stan-
dard Macintosh interface elements like text fields, check boxes, and selection lists.) Arachnid’s
Forms tools allow you to draw the specified objects directly on the page. When the Pointer
Tool is active (the Arrow icon), you can select, move, or clone Forms objects.

Arachnid Tool Descriptions
When you move the mouse pointer over any tool in the Tool palette, the functionality of that
tool is described in the text field at the bottom of the palette.
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Arachnid Tool Collapse Buttons
Near the right edge of Arachnid’s Tool palette are buttons for collapsing and expanding the
palette. Click an upward-pointing arrow to collapse the palette; click a downward-pointing
arrow to expand.

Arachnid Objects

OBJECTS PART 1: TEXT FIELDS

New text fields can be created two ways. With the Text Edit tool selected, you can create a new
field by clicking at any spot on the page where there is not already an object. If you import
text, a new text field is automatically generated to accommodate the text.  A field can contain
as little as a single character of text. As many as 30,000 characters can exist in a single field, and
a page can contain an unlimited number of fields. It is far better to use a large number of
individual fields for storing large amounts of text, as unavoidable slow down occurs when you
approach the storage limits of a field.

Whenever you create a new text field (either by clicking with the Text edit tool selected or by
importing text), it is always snapped to the left side of the page.

a

A click here . . .  . . . results in a text field like this.

When you first create a field, it is tall enough to accommodate a single line of text.
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The field automatically expands when additional text is entered.

If a field is limited to a single line of text, it can be dragged into line with other objects. Any
number of individual text fields can be in line together in the same row. Text fields containing
nothing but blank-space characters can be dragged in line to act as dividers between objects.

In the illustrations above and below, a text field is selected and is dragged upward and to the
right.
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The text field is then dropped into line with the other objects:

After the drop, there are four separate objects in the top row of this page.

Regardless of how much text is in a field, objects can be placed in line after the last character of
text in the field. Any type of object (except Rulers) can be placed after the last character in a
field, providing that it is not too wide to fit within the fixed horizontal dimensions of the page.
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If a text field contains nothing but blank space characters, the behavior is the same; objects can
be placed in line after the last blank character. Under normal defaults, only one single-space
character will separate objects when the page is converted to HTML.

Browsers, by default, will always collapse consecutive strings of space down into a single
space. If you open the Preferences Dialog box, you can enable Arachnid’s True Spacing Option.
This will force Browsers which support the HTML “non-breaking space” command to dupli-
cate exactly the spacing you put between and before words of text in text fields.
A field whose left edge is aligned to the left of the page can have its text alignment set as either
left- or center-aligned.
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Working with the text in a text field

Most of the basic text styling operations are the same as those in any word-processing pro-
gram. Simply select some text as you normally would, and pull down the Format menu.

The Styles menu contains standard commands for styling selected text in bold, italic, underline
or plain style. Note that Underline is not recognized as a valid style by all Browsers. If the field
is snapped to the left of the page, the Text Alignment menu can be used to set the text justifica-
tion of a field to Left or Center. Each text field is limited to one text-alignment  setting.

Six different sizes of Headers can be designated for selections of text. The visual result of
designating a Header is that the text becomes one of six sizes (24,18,14,12,10,9), and the style of
the text is set to Bold. In the case of a 12-point Header, the text style is also set to “Extended,”
to distinguish it from ordinary 12-point bold text.

The No Header command changes a header to plain text style.

The List menu allows you to designate selected text as related items in a List. At this time,
three of the five list styles are supported. You can designate an Unordered List (each list item
indented and preceded by a “•” character), an Ordered List (each list item indented and pre-
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ceded by its numerical position in the List), or a Definition List (each list item indented but
preceded by no special characters). The List Item command searches text above the selection to
find the last designated List item. The new item is designated as an item of that type of List.

To Undesignate text as a List or List Item, use the Remove List Item. You can also manually
delete the entire line of text. If you edit the text of a List Item, do not edit any of the Space
characters which were inserted to create the indented effect. You also should not edit any text
that is inserted before your list item. Removing or editing the • character or the number of an
Ordered List item can cause the List Item or entire List to  be incorrectly translated into HTML.

Arachnid’s Lists currently support only one level of List Nesting. To nest a List within another,
select some text that is immediately after another List Item, and designate it as a list style. To
nest the new list under the previous list, designate it as a List for a second time. The second
time you choose the List or List Item command, Arachnid sees that the text is already a List,
and that it is immediately after another list. The new list will be nested one level within the
outer list.
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OBJECTS PART 2: IN-LINE GRAPHICS (GIF FILES)

Because World Wide Web pages can contain graphical elements stored in external files, Arach-
nid provides you the means to import an image file of the appropriate type. The image is
displayed on the page, where it can be cloned or repositioned with respect to other objects.

There are certain restrictions regarding the name of a GIF file you import. The name of the file
must end with the four character string “.gif”. Upper case is also acceptable. Further, for a file
name to be valid according to the standards of the Internet, there can be no “/” characters or
blank space characters. Arachnid will reject any file which does not conform to those stan-
dards, with a message describing what was wrong with the file name.

An image of any size or resolution can be imported, but smaller images fare much better. Large
images may compromise Arachnid’s performance, and Arachnid’s locked page width might be
too small for some wide image files. Since the image is for on-screen display only, resolution
beyond 72dpi may be wasted.

The he image file must be in the same folder as your project, or within a folder that is within
the folder that contains your project.

To import an image file into a page, choose “Import Graphic” from the File menu or type
Command-I.

OBJECTS PART 3: RULERS (HORIZONTAL DIVIDING LINES)

The simplest of Arachnid’s basic screen objects are Horizontal Rulers, or dividing lines. These
rulers are used to physically divide sections of a page. Create Rulers using the Insert Ruler
command under the File menu, or by typing Command-R.

With the Pointer tool selected, you can reposition a Ruler on a page, or set any of three at-
tributes for it. A Ruler can be scaled both horizontally and vertically. For Rulers that are scaled
horizontally to a value less that 100%, the alignment of the Ruler can also be set: right, left, or
centered.

Since Rulers are always the only object within a given row on the page, you cannot drag them
into line with other objects. When you drag a ruler on top of another object or objects, Arach-
nid will shift those objects to a position beneath the Ruler.



 Arachnid User Guide ©1995 The University of Iowa 23 All rights reserved, but copy freely for non-commercial purposes.

Creating Forms with Arachnid
Many pages created for use on the WWW are not limited to interactive links to media and
other resources. A Web page can be much more interactive when it is designated as a Form.
Normally, this is done with an HTML command, but Arachnid handles it automatically as part
of its export to HTML sequence. When you have drawn interactive Form object on a page,
Arachnid automatically declares it as a Form in the HTML data it builds.

For a page to act as a Form, a specific URL must also be provided as the recipient of the mes-
sages and data which the page generates. Within the export sequence, Arachnid will prompt
the user to select one of the URLs from the URL database (Bookmark collection). A selected
URL can also be made the default for all Form pages encountered within the export sequence.

OBJECTS PART 4: BUTTONS

Arachnid buttons consist of three standard-style buttons familiar to anyone who has used a
Macintosh:

 Radio buttons

CheckBox buttons

 and RoundedRect buttons.

After selecting the appropriate tool for drawing a particular style of button, you can draw the
object directly onto the page. After you have drawn a button, you will need to supply some
data for Arachnid to use when defining the object in HTML. You always need to provide a
unique name for each button on a Page. The name of the button is assumed to be its value.
Each radio and checkbox button represents different choices of values for some particular
variable. When you create a radio or checkbox button, you can select from a list of variables
associated with buttons on the page, or you can create a new variable name.

The scope of a variable name you create is limited to the page containing the objects which use
the variable, so ten separate pages could each use their own version of a variable named “Op-
tions”. In the Active mode, radio and checkbox buttons behave as they will when the page is
converted to HTML and opened by a Browser. Radio buttons communicate with other buttons
tied to the same variable, allowing only one to be hilited at a time. Checkbox buttons toggle
their own hilite state.
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Rounded Rect buttons are limited to two types of operations which they can trigger. A
Rounded Rect button can “Reset” a Form, meaning to clear all information the user has en-
tered, or “Submit” which transmits the information within the page to the Server you specify
when the page is exported.

OBJECTS PART 5: FIELDS

You can create two types of text fields for Form pages: editable text fields and selection list
fields.

Unlike the editable text fields you normally work with, Form editable text fields are editable
when the page is accessed on the Internet. Furthermore, the text in a Form page editable text
field cannot be styled or linked to. Both scrolling and non-scrolling editable text fields can be
drawn on a Form page. The text of an editable text field can be edited within Arachnid any-
time the Text Edit tool is chosen or the Active Mode is chosen.

Selection list fields are always scrolling lists, but they can be configured to allow  a single
selection or multiple selections. Similar to editable text fields on a Form, selection list field text
cannot be stylized or linked to. When you are in the Text Edit mode, the text of a selection list
field can be edited. In the Active Mode, the field behaves as it will after being converted to
HTML and opened by a Browser.

OBJECTS PART 6: POP-UP MENU BUTTONS

The last type of object that you can create for a Form page is a Pop-up menu button. This type
of object is a combination of a button and a selection field. When you draw a Pop-up menu
button on the screen, you are prompted to give the button a name and to choose a Variable list
(menu) for the button. You can create new Variable lists (menus) when defining the button. A
Variable list can contain an unlimited number of items (menu commands).

When you click on a Pop-up menu button in the Active mode, the menu pops up, and the
visually displayed name of the button changes to reflect the choice you made in selecting from
the menu.



 Arachnid User Guide ©1995 The University of Iowa 25 All rights reserved, but copy freely for non-commercial purposes.

Creating HyperLinks in Arachnid

The third row on the Tool palette contains tools for creating links to selections of text or in-line
graphics.

To create a link, click and drag the icon representing the event of your choice. Drag the faint
gray rectangle until it is over the selected text or an in-line graphic, and release the mouse
button. A or File-like dialog appears, allowing you choose the file, page, or URL for the link.

The movie, image, and audio icons are limited to specific file types which Arachnid also
supports.

The Movie icon is limited to QuickTime movies (MooV), the Audio icon is limited to AIFF files,
and the Image icon supports linking to image files of type GIF, JPEG, or PICT.

A file of any type can be used as a link. The last icon, for linking to Files of Any Type, allows
you to set up links to files which Arachnid does not support.

Generic Link 

For instance, an MPEG file cannot be played back from within Arachnid, and a link to an
MPEG file cannot be created with the Movie link tool. Instead you would use the Generic File
icon. As long as the MPEG movie file’s name contains a valid extension (“.Mpeg”), Arachnid
will allow you to link to it.

To create links to other pages within your project, or to a specific span of text within a page in
your project, you use the Page Link and Text Link icons:

Page Link 

Text Link 
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When you create a link of these two styles, a File-like dialog appears for you to select a page
within your project as the destination for the link. You can link to any page within your
project, and you can create new pages from within the dialog during the linking process.

When you are creating a Text Link, Arachnid opens the page so that you can select the text
which will be the destination for the link. An additional palette opens when the text is selected

that you want to be the Link destination.

Click on the OK button to complete the link to the selected text.
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The final type of Link are URLs. A URL is a resource located somewhere on the internet. It can
point to literally anywhere in the World. To create a link to a URL, drag the URL Link Icon

URL Link Icon 

and drop it on some selected text or a graphic. A File-like dialog appears, which allows you to
select a URL for the link. Arachnid stores a name with each URL you enter or import from a
BookMark file. So a URL might show up in the list as “E-mail to Bob”. What is actually stored
with the “E-mail to Bob” label might be something like “mailto:robert-mcburney@uiowa.edu”.

Within this dialog, you can:

• edit the name and/or address information for any of your URLs

• select and delete URLs

• import the links within a BookMark file, or any other HTML file, into your list

• select a number of your URLs and Export them as a BookMark file

Because connecting to a URL requires a valid connection to the Internet, Arachnid’s Active
Mode behavior for URLs is limited to a simple message containing the address for the URL. In
Active mode, clicking on links to pages within the project—or links to spans of text in a page—
will trigger the behavior. Links to supported multimedia files (AIFF, MooV, GIF, JPEG, PICT)
results in the playback or presentation of that media file. Links to generic files will attempt to
launch the document with the creating application, so runtime behavior for generic files is also
somewhat limited.
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After you create a HyperLink, you will notice that visually, the text or graphic has changed.
The text and graphic border are color-coded to whatever default color for you specify for links.
To set this information, use the Preferences command in the File menu. This command pro-
duces a dialog where you can specify the background color for your page and the color for the
links. You can also set the default mode for handling blank-space characters when converting a
page to HTML.

Note: this color information currently is NOT exported as part of the HTML files, so color
changes are specific to the Arachnid project itself (but preserved if you want to distribute your
project on disk or CD, with the Arachnid Player).

The Preferences dialog section “Export to HTML Spacing Format” allows you to control the
spacing between and before words of text. Using Arachnid’s True Spacing Control will yield
an additional level of WYSIWYG. But this feature is not supported by all Browsers, and Brows-
ers which do not support this will produce unpredictable results.

Exporting to HTML

If you want to see what page will look like when viewed by your Browser, you will first need
to convert the page to HTML. The Export to HTML command is in the File menu. Converting
a page to HTML does NOT alter the page or project in any way. The result of the Export to
HTML is a new text file, created within the folder that contains your project. If your page is in
a project named “Default” and it is the fifth page of the project, the name of window contain-
ing the page is “Default-5”. After you export the page to HTML, a text file in the same folder is
named “Default-5.html”. This is the file that you open with your Browser.

Arachnid needs to access the file in question only for a single operation, so it is quite easy to
have both Arachnid and your Browser running at the same time and quickly bounce back and
forth between them, previewing your pages as you build them.

Since the file created by Arachnid’s export command is an ordinary textfile, it can be opened
by any program that can edit text. Advanced HTML users can still work at the deepest level
and use Arachnid as a fast way to structure a basic layout and define interactive behavior.
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DISTRIBUTING YOUR PROJECT WITH THE ARACHNID PLAYER

 Because Arachnid’s Active mode allows a high degree of multimedia playback capability,
Arachnid comes with a second application, the Arachnid Player. This tool is also Freeware, and
allows you to distribute your project on traditional media such as disk or CD-ROM. The
Arachnid Player is always set to Arachnid’s Active Mode, so no one can change your project
unless they also have the full Arachnid application.

You should bundle your project and all support media files using the same directory structure
that you used when building the project. In other words, make sure media files stored in sub-
directories are placed in sub-directories, with exactly the same naming conventions, when you
structure the folder for distribution.

Pages containing many links to URLs, or to file types not supported by Arachnid’s multimedia
playback capabilities, may NOT be best suited for this type of additional distribution. But
pages containing mainly links to other pages within the project, or to supported multimedia
files, are IDEAL candidates for distribution on disk.
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Support and Services

Thank you for using Arachnid. We at the University of Iowa are committed to continuing to
develop Arachnid. There is no intention of ever charging any kind of price for the product.
However, at this time, additional support for Arachnid is very limited. Problems, comments,
ideas, suggestions, or questions should be directed to:

Robert McBurney

100 LC

University of Iowa

Iowa City, IA 52242

e-mail at:

robert-mcburney@uiowa,edu

AppleLink:

mcburney.uia

BACKUP PROTECTION

You should always maintain a backup copy of Arachnid. Operations which add URLs to the
database, or add pages to the template database, physically alter the application itself. An
unexpected system crash during such an operation could corrupt the application’s file struc-
ture.

COPYRIGHT

This manual and the software described in it are copyrighted, with all rights reserved. Because
of the FreeWare status of the applications, the programs and the manual CAN be distributed
freely, providing that the manual is not altered in any way prior to distribution.

WARRANTIES

Because Arachnid is freeware, there are NO warranties or guarantees of any kind associated
with the program.
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TROUBLESHOOTING

If you are unable to decode the Arachnid compressed Archive after downloading, it may be
due to the utility you are using to decode the hqx data. The Arachnid compressed hqx file is
easily decoded and expanded by Stuffit Extractor, other binary decoding programs may not
work. This is probably due to incorrect encoding at our end. Future versions of Arachnid will
be encoded differently, hopefully making this problem disappear.
At this point, one genuine extension conflict has been identified with Arachnid. Power-
Macintosh systems using RAM Doubler tend to freeze up when attempting to import a GIF
image. Turning off RAM Doubler will alleviate the problem.

If you are not using this combination, and experience System freezes when importing a GIF,
try turning off all extensions, restarting, and repeating the import. If the machine does not
freeze when you import the GIF, you have located a new extension conflict. It would be greatly
appreciated if you could then take the time to identify the extension and notify the Arachnid
project team of the problem.

To identify the extension in question, after turning off ALL extensions, start turning them back
on, one at a time, restarting between each step, and testing Arachnid with the new extension
configuration. Eventually, you will run Arachnid with the extension causing the conflict, and
the machine will freeze.

If you are having problems importing large GIF files, Arachnid may be running out of
memory. Try increasing the amount of RAM allocated to Arachnid. To do this, locate the
Arachnid application file at the Finder level, select it, and Get Info (command-I). You can
adjust the memory settings near the bottom right-hand side of the window.


